mirror of
https://git.selfprivacy.org/SelfPrivacy/selfprivacy-rest-api.git
synced 2025-04-08 14:36:35 +00:00
42 lines
770 B
Nix
42 lines
770 B
Nix
{ pythonPackages, rev ? "local" }:
|
|
|
|
pythonPackages.buildPythonPackage {
|
|
pname = "selfprivacy-graphql-api";
|
|
version = rev;
|
|
src = builtins.filterSource (p: t: p != ".git" && t != "symlink") ./.;
|
|
propagatedBuildInputs = with pythonPackages; [
|
|
fastapi
|
|
gevent
|
|
huey
|
|
mnemonic
|
|
portalocker
|
|
psutil
|
|
pydantic
|
|
pytz
|
|
redis
|
|
systemd
|
|
setuptools
|
|
strawberry-graphql
|
|
typing-extensions
|
|
uvicorn
|
|
requests
|
|
websockets
|
|
httpx
|
|
passlib # password hasher
|
|
authlib
|
|
jinja2
|
|
itsdangerous
|
|
qrcode
|
|
pypng
|
|
python-multipart
|
|
bleach
|
|
argon2-cffi
|
|
];
|
|
pythonImportsCheck = [ "selfprivacy_api" ];
|
|
doCheck = false;
|
|
meta = {
|
|
description = ''
|
|
SelfPrivacy Server Management API
|
|
'';
|
|
};
|
|
}
|